Access to Stax Pay
Incident Report for Stax Payments
Resolved
This incident has been resolved. The third party vendor has returned to normal operations.
Posted Mar 13, 2023 - 12:21 EDT
Investigating
We are currently investigating an issue with our 3rd party vendor which may impact access to Stax Pay.
Posted Mar 13, 2023 - 11:47 EDT
This incident affected: Web Applications.