StaxPay Processing Issue
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 17:04 EST
Identified
We are aware of a small number of merchants who are having issues processing through StaxPay. We are actively working to resolve. This has no impact on Partners or their merchants.
Posted Mar 06, 2024 - 16:14 EST
This incident affected: Web Applications.