CrowdStrike Outage
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 07:48 EDT
Update
Our teams will be closely monitoring our systems over the weekend to ensure there are no residual impacts from today's CloudStrike outage.
Posted Jul 19, 2024 - 17:00 EDT
Update
We are continuing to monitor for impact from today's CloudStrike outage
Posted Jul 19, 2024 - 16:16 EDT
Update
We are continuing to monitor and investigate the global outage impact.
Posted Jul 19, 2024 - 14:56 EDT
Monitoring
We are monitoring our systems for any impact related to the current global outage related to CrowdStrike. We will continue to provide updates on this page.
Posted Jul 19, 2024 - 10:34 EDT