Funding Delay
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted May 03, 2024 - 16:39 EDT
Identified
We have identified the issue and merchants who have been impacted. We will continue to provide additional details to affected parties directly as needed.
Posted May 03, 2024 - 12:15 EDT
Investigating
We are currently aware that some merchants have experienced a delay in funding. Teams are currently investigating.
Posted May 03, 2024 - 11:25 EDT
This incident affected: Payments (Settlements, Fees, and Payouts).