Surcharging Fees

Incident Report for Stax Payments

Resolved

This incident has been resolved.
Posted Feb 15, 2024 - 18:55 EST

Investigating

We have detected a potential issue around surcharging fees. Teams are apprised of the situation and are actively investigating.
Posted Feb 15, 2024 - 16:02 EST
This incident affected: Payments (Settlements, Fees, and Payouts).