Multi-Factor Authentication SMS Delivery Delays
Incident Report for Stax Payments
Resolved
The SMS delivery issue has been resolved.
Posted Jun 05, 2024 - 16:44 EDT
Monitoring
Our SMS partner has addressed the issue and we are monitoring recovery.
Posted Jun 05, 2024 - 16:25 EDT
Investigating
We have been notified by our third party vendor Twilio that they are experiencing SMS delivery delays, which is impacting the ability for merchants to use Multi-Factor Authentication when accessing their Stax merchant account. Twilio is working on resolving the issue and we will continue to provide updates as they are made available.
Posted Jun 05, 2024 - 15:38 EDT
This incident affected: Notifications (SMS Notifications).