Hubspot Outage
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Aug 27, 2024 - 12:06 EDT
Identified
We are aware that HubSpot, is currently experiencing an issue that is affecting our ability to provide some customer and partner support. See HubSpot for more details.

We will resolve this incident once we have received confirmation the issue has been resolved from this provider.
Posted Aug 27, 2024 - 11:28 EDT