Potential Funding Delay
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Aug 06, 2024 - 09:17 EDT
Monitoring
A small portion of customers will experience a funding delay of one day.
Posted Aug 05, 2024 - 16:38 EDT
Identified
Some customers may experience potential funding delays.
Posted Aug 05, 2024 - 15:39 EDT
This incident affected: Payments (Settlements, Fees, and Payouts).