Outbound SMS Degradation

Incident Report for Stax Payments

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 00:57 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 12, 2025 - 00:56 EST

Update

We are continuing to work on a fix for this issue.
Posted Dec 12, 2025 - 00:19 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 12, 2025 - 00:19 EST

Monitoring

We are continuing to work on a fix for this issue.
Posted Dec 12, 2025 - 00:00 EST

Update

We are continuing to work on a fix for this issue.
Posted Dec 11, 2025 - 23:47 EST

Update

We are continuing to work on a fix for this issue.
Posted Dec 11, 2025 - 20:29 EST

Update

We are continuing to work on a fix for this issue.
Posted Dec 11, 2025 - 20:29 EST

Identified

We are currently experiencing an issue affecting outbound text messaging (SMS). Some users may experience be impacted outbound messages. Our team has identified the problem and is actively working toward a resolution. Further updates will be provided as more information becomes available.
Posted Dec 11, 2025 - 20:21 EST
This incident affected: Notifications (SMS Notifications).