Funding Delay Due to Processor Outage
Incident Report for Stax Payments
Resolved
First Data has informed us that a subset of merchants who use the North, Omaha, or South Back End platform may experience a one business day delay in funding.

First Data continues to work through final resolution and we will continue to monitor the environment.
Posted Feb 02, 2024 - 17:15 EST
Monitoring
We have just been notified by our third-party vendor, First Data, that some merchants may have experienced a funding delay with their February 1, 2024 settlement. This outage has no impact on Partners or their merchants.

First Data is working to correct this issue and ensure that all merchants have their funds as quickly as possible. Our support teams are apprised of the situation and fielding inbound customer inquiries.
Posted Feb 02, 2024 - 12:00 EST
This incident affected: Payments (Settlements, Fees, and Payouts).