Intermediate Fee Statement Loading Issues
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Aug 06, 2024 - 13:36 EDT
Investigating
Teams are continuing to investigate intermittent issues with the loading of fee statements in Stax Pay and Stax Connect.
Posted Aug 06, 2024 - 10:46 EDT
This incident affected: Analytics and Reporting.