Deposit Report Delay
Incident Report for Stax Payments
Resolved
Deposit Reports for 12/7 are now available. The issue has been resolved.
Posted Dec 07, 2023 - 14:21 EST
Identified
We have identified a delay with displaying Deposit Reports from 12/7 for some merchants. Our teams are actively working on a resolution and will continue to provide updates.
Posted Dec 07, 2023 - 09:06 EST