MMS Delay
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Nov 05, 2024 - 17:13 EST
Identified
We are aware that Twilio is currently experiencing an issue that is causing a delay in receiving MFA codes if requested. See https://status.twilio.com/ for more details.

We will resolve this incident once we have received confirmation the issue has been resolved from this provider.
Posted Nov 05, 2024 - 15:24 EST
This incident affected: Notifications (SMS Notifications).