Platform Error Message
Incident Report for Stax Payments
Resolved
Engineers have identified and resolved the issue. Teams will continue to monitor the environment.
Posted Jan 10, 2024 - 09:11 EST
Investigating
We have identified an issue related to our StaxPay platform that may impact access for some customers. Our teams are working on a resolution and will continue to provide updates.
Posted Jan 10, 2024 - 08:19 EST
This incident affected: Web Applications.