Vantiv Now Worldpay eCommerce Processing Errors

Incident Report for Stax Payments

Resolved

Transactions are now succeeding on the WorldPay platform. Engineers are continuing to monitor for any issues.
Posted Nov 14, 2023 - 09:43 EST

Monitoring

We have been made aware that our 3rd Party vendor, WorldPay, is experiencing an outage which is impacting some processing for our customers.

We are actively monitoring the situation and fielding customer inquiries and will continue to keep you updated.
Posted Nov 14, 2023 - 09:22 EST