System Stability Issues

Incident Report for Stax Payments

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 08:36 EDT

Monitoring

Systems have recovered and teams are continuing to monitor.
Posted Mar 10, 2026 - 18:43 EDT

Identified

The team is aware of the issues related to the inability to access Stax Pay and Connect.
Posted Mar 10, 2026 - 18:35 EDT
This incident affected: Web Applications.