Payment Service Disruption

Incident Report for Stax Payments

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 14:28 EST

Monitoring

A fix has been implemented, and we are seeing recovery in the affected systems. We will continue to monitor the results.
Posted Nov 05, 2025 - 11:36 EST

Investigating

We have identified a technology outage causing an issue with processing payments. Teams are working to identify the root cause and implement a solution.
Posted Nov 05, 2025 - 11:13 EST
This incident affected: Payments (Scheduled Payments, Stax API).