Issue with 3rd Party Vendor - NMI Performance Degradation
Incident Report for Stax Payments
Resolved
NMI Resolved its issue.
Posted Oct 11, 2024 - 08:42 EDT
Monitoring
NMI reporting a fix has been applied. We are closely monitoring.
Posted Oct 10, 2024 - 18:34 EDT
Investigating
We are aware that NMI is currently experiencing an issue that is affecting our ability to process some credit card payments in a timely manner. See https://status.transactiongateway.com/ for more details.

We will resolve this incident once we have received confirmation the issue has been resolved from this provider.
Posted Oct 10, 2024 - 18:22 EDT