3rd Party Outage

Incident Report for Stax Payments

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 16:38 EDT

Identified

We are aware that Spreedly is currently experiencing an issue that is affecting our ability to accept payments. See Spreedly's Status Page for more details.
https://status.spreedly.com/

We will resolve this incident once we have received confirmation the issue has been resolved from this provider.
Posted Apr 14, 2025 - 16:26 EDT
This incident affected: Payments (Scheduled Payments, Stax API).