Cloud Infrastructure Degradation

Incident Report for Stax Payments

Resolved

Our third-party cloud provider has confirmed that the network latency issue has been resolved and all systems are working as expected.
Posted Sep 19, 2023 - 06:43 EDT

Monitoring

Platform availability and response times are recovering. Our teams continue to monitor the recovery.
Posted Sep 18, 2023 - 15:57 EDT

Investigating

We are currently investigating an issue indicated by a third-party cloud provider where network latency is degrading the performance of our web platforms.
Posted Sep 18, 2023 - 15:12 EDT
This incident affected: Web Applications, Mobile Applications and Payments (Stax API).