System Stability Issues

Incident Report for Stax Payments

Monitoring

The system has been stabilized and we are continuing to monitor.
Posted Apr 16, 2026 - 13:21 EDT

Investigating

We are aware of system stability issues and teams are actively working to resolve the issue.
Posted Apr 16, 2026 - 12:43 EDT
This incident affects: Web Applications and Payments (Scheduled Payments, Stax API, Settlements, Fees, and Payouts).