Service Disruption

Incident Report for Stax Payments

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 16:24 EDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Sep 11, 2025 - 12:18 EDT

Identified

We have identified the issue and are currently working on a resolution. We will continue to provide updates.
Posted Sep 11, 2025 - 09:45 EDT

Investigating

We are currently investigating a service disruption with our Stax Pay Platform. Teams are working to identify the root cause and implement a solution.
Posted Sep 11, 2025 - 08:47 EDT
This incident affected: Web Applications.