Potential Settlement Issue

Incident Report for Stax Payments

Resolved

This incident has been resolved.
Posted Nov 16, 2023 - 16:56 EST

Identified

We have just identified an issue with payouts originally scheduled for today, which may result in merchants experiencing inaccurate daily settlements.

We are actively investigating the situation
Posted Nov 16, 2023 - 13:26 EST