Onboarding and Disputes
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 09:17 EDT
Update
We are continuing to observe a reduction of impact to customers within our systems. Updates will continue to be provided.
Posted Jul 25, 2024 - 17:20 EDT
Monitoring
A fix has been implemented and we are monitoring signs of recovery. We will continue to provide updates.
Posted Jul 25, 2024 - 14:00 EDT
Identified
We have identified an issue related to some features within Onboarding and Disputes handling that may be impacting a small subset of customers. Our teams are working on a resolution and will continue to provide updates.
Posted Jul 25, 2024 - 12:45 EDT