Deposit Delays
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 07:52 EST
Identified
Our teams have confirmed that payouts were missed for a subset of merchants. Those payouts have been released and confirmed and will be available at the merchants’ banks for posting today.

Teams also continue to work to confirm the root cause.
Posted Feb 21, 2024 - 12:59 EST
Investigating
We are receiving reports that some merchants are experiencing deposit delays expected for Tuesday, February 20th.

Our teams are actively working to determine the root cause and remediation so that we can provide updates on deposit timing for the impacted merchants.
Posted Feb 21, 2024 - 10:33 EST
This incident affected: Payments (Settlements, Fees, and Payouts).