DialPad Outage
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 16:18 EDT
Identified
We are aware that DialPad is currently experiencing an outage that is affecting our ability to accept incoming customer calls. See DialPad's status page for more details: https://status.dialpad.com/

We will resolve this incident once we have received confirmation the issue has been resolved from this provider.
Posted Oct 08, 2024 - 15:47 EDT
This incident affected: Customer Support (Inbound Calling).