Transaction Errors
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Jun 12, 2024 - 17:56 EDT
Monitoring
We are aware of an issue that occurred which prevented some transactions from processing on our platform. Teams have identified the issue and implemented a fix.

We will continue to monitor the platform for stability.
Posted Jun 12, 2024 - 17:17 EDT
This incident affected: Payments (Scheduled Payments, Stax API).