Refund Deposit Discrepancies

Incident Report for Stax Payments

Resolved

This incident has been resolved.
Posted Sep 28, 2023 - 15:50 EDT

Identified

We are aware of an issue where fees and/or transaction refunds are being incorrectly debited from merchant accounts. We have identified the issue with a processing partner and are working with them to resolve the issue.
Posted Sep 14, 2023 - 20:16 EDT
This incident affected: Payments (Stax API).