Fee Statements

Incident Report for Stax Payments

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 08:32 EDT

Identified

The issue has been identified and teams are working to implement a fix.
Posted Mar 10, 2026 - 10:57 EDT

Investigating

We are currently investigating intermittent issues with the loading of fee statements.
Posted Mar 10, 2026 - 09:51 EDT
This incident affected: Analytics and Reporting.