Payment Service Disruption

Incident Report for Stax Payments

Resolved

This incident has been resolved
Posted Oct 13, 2025 - 17:13 EDT

Identified

We have identified a technology outage causing an issue with processing payments. Teams are working to identify the root cause and implement a solution.
Posted Oct 13, 2025 - 16:03 EDT
This incident affected: Payments (Scheduled Payments, Stax API).