Issue with 3rd Party Vendor - Twillo
Incident Report for Stax Payments
Resolved
Twillo has resolved the incident.
Posted Oct 24, 2024 - 20:35 EDT
Monitoring
Twillo is reporting recovery with SMS and MMS Text Messaging with the specific US Carriers. We will resolve this incident once we have received confirmation the issue has been resolved from this provider.
Posted Oct 24, 2024 - 19:07 EDT
Investigating
We are aware that Twillo, is currently experiencing an issue that is causing delays is receiving SMS and MMS Text Messages with specific US Carriers. See https://status.twilio.com/ for more details.

We will resolve this incident once we have received confirmation the issue has been resolved from this provider.
Posted Oct 24, 2024 - 12:55 EDT