Delayed Reporting
Incident Report for Stax Payments
Resolved
Reports are now available, the issue has been resolved.
Posted Nov 29, 2023 - 13:32 EST
Identified
We have identified an issue where deposit reports from 11/27 are delayed. Our teams are working on a resolution and will continue to provide updates.
Posted Nov 29, 2023 - 10:37 EST