Funding Delays
Incident Report for Stax Payments
Resolved
We have been notified by one of our partners that some customers may experience funding delays for their deposits expected today, 10/11. The issue has been identified and we are currently working with our partner on a resolution. We will continue to provide additional details to affected parties directly as needed.
Posted Oct 12, 2023 - 10:14 EDT
Identified
We have been notified by one of our partners that some customers may experience funding delays for their deposits expected today, 10/11. The issue has been identified and we are currently working with our partner on a resolution. We will continue to provide additional details to affected parties directly as needed.
Posted Oct 11, 2023 - 10:23 EDT
This incident affected: Payments (Settlements, Fees, and Payouts).