Scheduled Payments
Incident Report for Stax Payments
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 18:17 EDT
Monitoring
A fix has been implemented. We are monitoring the results.
Posted Apr 19, 2024 - 18:06 EDT
Identified
Engineering has identified the issue and are working on a fix.
Posted Apr 19, 2024 - 15:44 EDT
Investigating
We are aware that some scheduled payments are not showing up for certain users. Engineering teams are aware and investigating.
Posted Apr 19, 2024 - 15:33 EDT
This incident affected: Payments (Scheduled Payments).